Jump to content
TNC-TR
crasadure

Multiboot Toolkit V2.2.0(multiboot System-uefi/legacy)

Recommended Posts

@crasadure hocam multiboot Toolkit uzun süredir güncelleme almıyor malum: siz ne kullanıyorsunuz şu an: ben döndüm dolaştım  2.2.0 kullanıyorum: betaları hiç denedim. Bu gün 256lık 3.1 flash diskim gelecek 2.2.0 kurmayı düşünüyorum: başka bir öneriniz olur mu?

Edited by efe34

Share this post


Link to post
Share on other sites
efe34, 3 saat önce yazdı:

@crasadure hocam multiboot Toolkit uzun süredir güncelleme almıyor malum: siz ne kullanıyorsunuz şu an: ben döndüm dolaştım  2.2.0 kullanıyorum: betaları hiç denedim. Bu gün 256lık 3.1 flash diskim gelecek 2.2.0 kurmayı düşünüyorum: başka bir öneriniz olur mu?

Ben de multiboot toolkit v2.2.0 kullanıyorum,devamlı sistem değiştirmeyi sevmiyorum.her sistem değişikliğinde onca ISO dosyasını flash a kopyalamak,ayar yapmak bana zor geliyor..şu an bu sistem benim her işimi görüyor..Tercih sizin,hangi sistemi kullanırsanız kullanın temel maksat tüm sistemleri çalıştırabilen bir multiboot kullanmaktır. 3 seçenek var bana göre...

1. KM Boot 

2. AIO Boot

3. Multiboot Toolkit

Üçünün de anlatımları sitede mevcut. Hangini tercih ederseniz ?

  • Thanks 1

Share this post


Link to post
Share on other sites

@crasadure hocam multiboot toolkit v2.2.0'ı 16 gb usb belleğe kurmak istiyorum ama belleğimi kurulum ekranında göremiyorum sebebi ne olabilir? bilgisayarda 2 tane harddisk var sadece onları gösteriyor, usb belleği normal şekilde bilgisayara takıp kullanabiliyorum sıkıntı olmuyor. Çözümü varmıdır? (bu arada usb bellek ntfs formatlı)

 

 

 

 

 

 

 

 

 

 

 

0

Edited by FireWalkeR

Share this post


Link to post
Share on other sites
FireWalkeR, 3/14/2018 - 11:56 yazdı:

@crasadure hocam multiboot toolkit v2.2.0'ı 16 gb usb belleğe kurmak istiyorum ama belleğimi kurulum ekranında göremiyorum sebebi ne olabilir? bilgisayarda 2 tane harddisk var sadece onları gösteriyor, usb belleği normal şekilde bilgisayara takıp kullanabiliyorum sıkıntı olmuyor. Çözümü varmıdır? (bu arada usb bellek ntfs formatlı)

 

w10 1709 ise işletim sisteminiz sanalda 1703 kurun: ilk kurulumu sanaldan yapın: denemiştim

1703 zamanından beri güncelleme yok: çok güzel bir sistemdi ama yapımcı güncellemeyi bıraktı: aioboot tavsiye ederim: konusu açıldı yeni @crasadure tarafından

https://www.tnctr.com/topic/424897-aioall-in-one-bootable-multiboot-multiboot-usb-creator/

Edited by efe34
  • Thanks 1

Share this post


Link to post
Share on other sites

Sistem güzel ancak 1920 x 1080 hp laptopta  ana memü dışında bazı menüler  görüntülenmiyor  mesela ekran devrik  ve üstüste biniyor ekrandaki görüntüler  

Share this post


Link to post
Share on other sites
ayhantoka, Bir saat önce yazdı:

Sistem güzel ancak 1920 x 1080 hp laptopta  ana memü dışında bazı menüler  görüntülenmiyor  mesela ekran devrik  ve üstüste biniyor ekrandaki görüntüler  

Multiboot Toolkit v2.2.0 da sizin dediğiniz ve belirttiğiniz çözünürlük değerini ana sayfada destekliyor;bu aşağıdaki resimde görülüyor(main.cfg dosyası)

cozunurluk.JPG.f5ddcf6eedde23ed6a9ea7a9aa4e4ec3.JPG

eğer diğer cfg dosyalarında çözünürlük kayıyorsa o zaman yukarıdaki resimde yar alan 1-24.satırlar arasındaki kodları her cfg dosyasına eklerseniz çözünürlük desteği her sayfada doğru bir şekilde olacaktır.

insmod font
if loadfont unicode ; then
    if keystatus --shift ; then true ; else
        if [ "${grub_platform}" == "efi" ]; then
            insmod efi_gop
            insmod efi_uga
        else
            insmod vbe
            insmod vga
        fi
            insmod gfxterm
            set gfxmode=1920x1080,1024x768,800x600,auto
            set gfxpayload=auto
            terminal_output gfxterm
        if terminal_output gfxterm ; then true ; else
            terminal gfxterm
        fi
    fi
fi

if [ "${grub_platform}" == "pc" ]; then
    insmod vbe
    insmod vga
fi

 

Edited by crasadure
  • Thanks 1

Share this post


Link to post
Share on other sites
ayhantoka, Bir saat önce yazdı:

1920 x 1080  listede olmadığı için  görüntü bozulmuş olabilirmi 

Resime iyi bakarsanız, bahsettiğiniz çözünürlük resim olarak paylaştığım 12.satırda okla gösterdim.yani sizin çözünürlük zaten destekleniyor...sadece diğer cfg dosyalarında çözünürlük ayarı olmadığından alt sayfalarda çözünürlük kaymaktadır...diğer cfg dosyalarında çözünürlüğün doğru gözükmesi için burada paylaştığım kodları diğer cfg dosyalarına da eklemeniz yeterli olacaktır.

Share this post


Link to post
Share on other sites

sadece grup klasöründeki bütün cfg dosyalarını gözden geçirmem yeterli sanırım

başka klasörde düzenlemesi gereken cfg dosyası varmı

 

şimdiden teşekkürler

ayrıca lst dosyalarında işlem varmı

Edited by ayhantoka

Share this post


Link to post
Share on other sites

Kmpe 8-10 (x86/x64/ Native.x86) 18.03.2018 projesinin Multiboot Toolkit programına entegrasyonu

1. KMPE klasörünün tamamını kök dizine kopyalayın

2. EFI klasörü altına aşağıdaki dosyaları kopyalayın.

EFI.rar

3. /BOOT/GRUB/main.cfg dosyasına aşağıdaki kodları ekleyin

if [ "${grub_platform}" == "pc" ]; then
if [ -e "/KMPE/Bootmgr" ]; then
   menuentry "Karadurak WinPE 10 x86x64(LEGACY)" {
       search --file /KMPE/Bootmgr --set=root
       insmod ntldr
       ntldr /KMPE/Bootmgr
   }
   fi
 fi

if [ "${grub_platform}" == "efi" ]; then
	if [ -e "/EFI/BOOT/KMPEx64.efi" ]; then
 	menuentry "Karadurak WinPE 10 x86x64(UEFI)" {
    echo "Karadurak WinPE Başlatılıyor, Lütfen Biraz Bekleyin..."
	insmod usbms
	insmod part_gpt
	insmod part_msdos
	insmod fat
	insmod chain
	chainloader /EFI/BOOT/KMPEx64.efi
	}
  	fi
fi

4. Islem tamam...

 

ayhantoka, 19.03.2018 - 10:00 yazdı:

sadece grup klasöründeki bütün cfg dosyalarını gözden geçirmem yeterli sanırım

başka klasörde düzenlemesi gereken cfg dosyası varmı

 

şimdiden teşekkürler

ayrıca lst dosyalarında işlem varmı

evet  grub altındaki cfg dosyalarına ekleme yapmanız yeterli....bu grub2 ekranındaki çözünürlük sorununuzu halledecektir.

lst dosyalarında ise GFX menu kullanıldığı için; eğer GFX menü ler  1920x1080 çözünürlüğünde ayarlanmışsa sorun çıkarmayacaktır.

Edited by crasadure
  • Thanks 1

Share this post


Link to post
Share on other sites

CDtSQktgp-1G2a-6F7iAivyfMSXTaHDKUG7J2Xhc 

Usb bellek değişimi sebebi ile yeni bir usb belleğe tekrardan kurulum yaptım (2.2.0).  Acronis imaj dosyamı ati16.iso adıyla /iso klasörüne attım ama açarken bu hatayı aldım. Daha önceki belleğimdede aynı şekilde kullanıyordum ve bir hata almıyordum. Yardımcı olabilir misiniz ?

Share this post


Link to post
Share on other sites
xSwindLer, 3 saat önce yazdı:


Usb bellek değişimi sebebi ile yeni bir usb belleğe tekrardan kurulum yaptım (2.2.0).  Acronis imaj dosyamı ati16.iso adıyla /iso klasörüne attım ama açarken bu hatayı aldım. Daha önceki belleğimdede aynı şekilde kullanıyordum ve bir hata almıyordum. Yardımcı olabilir misiniz ?

resim görünmüyor

Edited by efe34

Share this post


Link to post
Share on other sites
xSwindLer, 3 saat önce yazdı:

CDtSQktgp-1G2a-6F7iAivyfMSXTaHDKUG7J2Xhc 

Usb bellek değişimi sebebi ile yeni bir usb belleğe tekrardan kurulum yaptım (2.2.0).  Acronis imaj dosyamı ati16.iso adıyla /iso klasörüne attım ama açarken bu hatayı aldım. Daha önceki belleğimdede aynı şekilde kullanıyordum ve bir hata almıyordum. Yardımcı olabilir misiniz ?

öncelikle resim dosyası görünmüyor...yardımcı olabilmemiz için ISO yu attğınız klasör'ün ve dosya adının resmini atın...ayrıca Acronics'i çalıştırmak için kullandığın kodları eklersen yardımcı olabiliriz...

Bende Acronics 2010 ve 2017 versiyonları için klasör görüntüsü ve gerekli kodlar şu şekildedir

klasör yapısı

acronics_iso_klasor.JPG.829b90dff11ee11fb38f648fafd3ec81.JPG

gerekli olan kodlar

Spoiler
if [ "${grub_platform}" == "pc" ]; then
if [ -e "/BOOT/GRUB/grub.exe" ]; then
if [ -e "/ISO/ati10.iso" ]; then
  menuentry "Acronis True Image 2010" --class Acronis {
  set opts='map /ISO/ati10.iso (0xff);
            map --hook;
            chainloader (0xff);'
  linux16 /BOOT/GRUB/grub.exe --config-file=${opts}
}
fi
fi
fi


if [ "${grub_platform}" == "pc" ]; then
if [ -e "/BOOT/GRUB/grub.exe" ]; then
if [ -e "/ISO/ati17.iso" ]; then
  menuentry "Acronis True Image 2017" --class Acronis {
  set opts='map /ISO/ati17.iso (0xff);
            map --hook;
            chainloader (0xff);'
  linux16 /BOOT/GRUB/grub.exe --config-file=${opts}
}
fi
fi
fi

 

 

Share this post


Link to post
Share on other sites
crasadure, 08.04.2018 - 20:38 yazdı:

öncelikle resim dosyası görünmüyor...yardımcı olabilmemiz için ISO yu attğınız klasör'ün ve dosya adının resmini atın...ayrıca Acronics'i çalıştırmak için kullandığın kodları eklersen yardımcı olabiliriz...

Bende Acronics 2010 ve 2017 versiyonları için klasör görüntüsü ve gerekli kodlar şu şekildedir

klasör yapısı

acronics_iso_klasor.JPG.829b90dff11ee11fb38f648fafd3ec81.JPG

gerekli olan kodlar

  İçeriği Görüntüle

if [ "${grub_platform}" == "pc" ]; then
if [ -e "/BOOT/GRUB/grub.exe" ]; then
if [ -e "/ISO/ati10.iso" ]; then
  menuentry "Acronis True Image 2010" --class Acronis {
  set opts='map /ISO/ati10.iso (0xff);
            map --hook;
            chainloader (0xff);'
  linux16 /BOOT/GRUB/grub.exe --config-file=${opts}
}
fi
fi
fi


if [ "${grub_platform}" == "pc" ]; then
if [ -e "/BOOT/GRUB/grub.exe" ]; then
if [ -e "/ISO/ati17.iso" ]; then
  menuentry "Acronis True Image 2017" --class Acronis {
  set opts='map /ISO/ati17.iso (0xff);
            map --hook;
            chainloader (0xff);'
  linux16 /BOOT/GRUB/grub.exe --config-file=${opts}
}
fi
fi
fi

 

 

Fotoğraf bende görünüyor ama tekrardan yüklüyorum kusura bakmayın. https://prnt.sc/j31b5p 
Söylediğiniz kod kısmı hangisi bilmiyorum :( 

Share this post


Link to post
Share on other sites
xSwindLer, Bir saat önce yazdı:

Fotoğraf bende görünüyor ama tekrardan yüklüyorum kusura bakmayın. https://prnt.sc/j31b5p 
Söylediğiniz kod kısmı hangisi bilmiyorum :( 

/Boot/Grub/ klasörü altında "cfg" uzantılı dosyaların içinde ati16.iso dosyasını çağıran komut ifadeleri mevcuttur...örneğin yukarıdaki kodlar benim "partition.cfg içinde yer almaktadır. senin ati16.iso yu çalıştırman için gerekli kodlar şu şekilde olmalı

if [ "${grub_platform}" == "pc" ]; then
if [ -e "/BOOT/GRUB/grub.exe" ]; then
if [ -e "/ISO/ati16.iso" ]; then
  menuentry "Acronis True Image 2016" --class Acronis {
  set opts='map /ISO/ati16.iso (0xff);
            map --hook;
            chainloader (0xff);'
  linux16 /BOOT/GRUB/grub.exe --config-file=${opts}
}
fi
fi
fi

 

Share this post


Link to post
Share on other sites
crasadure, 10.04.2018 - 01:02 yazdı:

/Boot/Grub/ klasörü altında "cfg" uzantılı dosyaların içinde ati16.iso dosyasını çağıran komut ifadeleri mevcuttur...örneğin yukarıdaki kodlar benim "partition.cfg içinde yer almaktadır. senin ati16.iso yu çalıştırman için gerekli kodlar şu şekilde olmalı

if [ "${grub_platform}" == "pc" ]; then
if [ -e "/BOOT/GRUB/grub.exe" ]; then
if [ -e "/ISO/ati16.iso" ]; then
  menuentry "Acronis True Image 2016" --class Acronis {
  set opts='map /ISO/ati16.iso (0xff);
            map --hook;
            chainloader (0xff);'
  linux16 /BOOT/GRUB/grub.exe --config-file=${opts}
}
fi
fi
fi

 

Dediğiniz kodları ekleyip tekrar 2 farklı bilgisayarda denedim ama yine aynı hatayı aldım.  Başka bir çözüm yöntemi var mı acaba bildiğiniz ?

Share this post


Link to post
Share on other sites
xSwindLer, 39 dakika önce yazdı:

Dediğiniz kodları ekleyip tekrar 2 farklı bilgisayarda denedim ama yine aynı hatayı aldım.  Başka bir çözüm yöntemi var mı acaba bildiğiniz ?

Grub4dos kısmında İSO Mount seçeneği ile ati16.iso dosyasını çalıştırmayı deneyin..oradan kesinlikle calisacaktir

58dd769aec5a8_EkranAlnts2.JPG.303b55be4e1649a5354254436a4e8fbb.JPG

Share this post


Link to post
Share on other sites
mmtsahindmn, 8 dakika önce yazdı:

beyler elinde olan varsa link versin program piyasadan silinmiş

upload ediyorum

Edited by efe34

Share this post


Link to post
Share on other sites

Konuyu düzenleme yetkim şu an için yönetim tarafından alınmış durumda..yetkiyi alır almaz ana konu başlığındaki link guncellenecektir

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×